Discussion:
Radosgw - ls not showing some files, invisible files
(too old to reply)
Enrico Kern
2018-02-09 13:27:31 UTC
Permalink
Hello,

we run ceph 12.2.2. Now the multipart upload problem with replication to
other zones were fixed but we do not see all files in a bucket with ls via
API, cyberduck etc.

example we have a bucket with alot of files. The file list is complete in
our second datacenter and i can see all files in the bucket.

On the main datacenter which replicated this files to the other one i have
some "invisible" files. I cannot see them in the api responses or utilizing
some client like s3cmd, cyberduck etc. But the files is there i can see the
details with

radosgw-admin object stat

and i also verified the file is available in the pool.

Anyone had this behavior before that some files are kind of invisible?
--
Enrico Kern
*Director of System Engineering*

*T* +49 (0) 30 555713017 | *M *+49 (0)152 26814501
*E* ***@glispa.com | *Skype flyersa* | LinkedIn View my Profile
<https://www.linkedin.com/in/enricokern/>



*Glispa GmbH* - Berlin Office
Sonnenburger Str. 73 10437 Berlin, Germany
Managing Director: Dina Karol-Gavish, Registered in Berlin, AG
Charlottenburg HRB 114678B
<http://www.glispa.com/> <***@glispa.com>
<https://www.linkedin.com/company-beta/143634/>
<https://plus.google.com/u/0/b/116135915389937318808/116135915389937318808>
<https://twitter.com/glispa> <https://www.facebook.com/glispamedia/>
<https://www.instagram.com/glispaglobalgroup/>
Loading...