Discussion:
Help:mount error
(too old to reply)
于泓海
2015-01-28 06:48:09 UTC
Permalink
Hi£º


I have completed the installation of ceph cluster,and the ceph health is ok£º


cluster 15ee68b9-eb3c-4a49-8a99-e5de64449910
health HEALTH_OK
monmap e1: 1 mons at {ceph01=10.194.203.251:6789/0}, election epoch 1, quorum 0 ceph01
mdsmap e2: 0/0/1 up
osdmap e16: 2 osds: 2 up, 2 in
pgmap v729: 92 pgs, 4 pools, 136 MB data, 46 objects
23632 MB used, 31172 MB / 54805 MB avail
92 active+clean


But when i mount from client,the error is: mount error 5 = Input/output error.
I have tried lots of ways,for ex:disable selinux,update kernel...
Could anyone help me to resolve it? Thanks!




Jason



--
王亚洲
2015-01-28 06:54:33 UTC
Permalink
hi£º
if you do "ceph fs new" command? I encounter the same issue without doing "ceph fs new".






At 2015-01-28 14:48:09, "ÓÚãüº£" <foxconn-***@163.com> wrote:

Hi£º


I have completed the installation of ceph cluster,and the ceph health is ok£º


cluster 15ee68b9-eb3c-4a49-8a99-e5de64449910
health HEALTH_OK
monmap e1: 1 mons at {ceph01=10.194.203.251:6789/0}, election epoch 1, quorum 0 ceph01
mdsmap e2: 0/0/1 up
osdmap e16: 2 osds: 2 up, 2 in
pgmap v729: 92 pgs, 4 pools, 136 MB data, 46 objects
23632 MB used, 31172 MB / 54805 MB avail
92 active+clean


But when i mount from client,the error is: mount error 5 = Input/output error.
I have tried lots of ways,for ex:disable selinux,update kernel...
Could anyone help me to resolve it? Thanks!




Jason



--
于泓海
2015-01-28 07:14:51 UTC
Permalink
Hi Wang:


I have created the pool and fs before.




--

ÔÚ 2015-01-28 14:54:33£¬"ÍõÑÇÖÞ" <***@163.com> ÐŽµÀ£º

hi£º
if you do "ceph fs new" command? I encounter the same issue without doing "ceph fs new".






At 2015-01-28 14:48:09, "ÓÚãüº£" <foxconn-***@163.com> wrote:

Hi£º


I have completed the installation of ceph cluster,and the ceph health is ok£º


cluster 15ee68b9-eb3c-4a49-8a99-e5de64449910
health HEALTH_OK
monmap e1: 1 mons at {ceph01=10.194.203.251:6789/0}, election epoch 1, quorum 0 ceph01
mdsmap e2: 0/0/1 up
osdmap e16: 2 osds: 2 up, 2 in
pgmap v729: 92 pgs, 4 pools, 136 MB data, 46 objects
23632 MB used, 31172 MB / 54805 MB avail
92 active+clean


But when i mount from client,the error is: mount error 5 = Input/output error.
I have tried lots of ways,for ex:disable selinux,update kernel...
Could anyone help me to resolve it? Thanks!




Jason



--
Lindsay Mathieson
2015-01-28 07:04:52 UTC
Permalink
Your mount command?

Lindsay Mathieson

-----Original Message-----
From: "于泓海" <foxconn-***@163.com>
Sent: ‎28/‎01/‎2015 4:48 PM
To: "ceph-***@ceph.com" <ceph-***@ceph.com>
Subject: [ceph-users] Help:mount error

Hi


I have completed the installation of ceph cluster,and the ceph health is ok


cluster 15ee68b9-eb3c-4a49-8a99-e5de64449910
health HEALTH_OK
monmap e1: 1 mons at {ceph01=10.194.203.251:6789/0}, election epoch 1, quorum 0 ceph01
mdsmap e2: 0/0/1 up
osdmap e16: 2 osds: 2 up, 2 in
pgmap v729: 92 pgs, 4 pools, 136 MB data, 46 objects
23632 MB used, 31172 MB / 54805 MB avail
92 active+clean


But when i mount from client,the error is: mount error 5 = Input/output error.
I have tried lots of ways,for ex:disable selinux,update kernel...
Could anyone help me to resolve it? Thanks!




Jason



--
Yan, Zheng
2015-01-28 14:35:45 UTC
Permalink
Post by 于泓海
Hi:
I have completed the installation of ceph cluster,and the ceph health is
ok:
cluster 15ee68b9-eb3c-4a49-8a99-e5de64449910
health HEALTH_OK
monmap e1: 1 mons at {ceph01=10.194.203.251:6789/0}, election epoch 1, quorum 0 ceph01
mdsmap e2: 0/0/1 up
osdmap e16: 2 osds: 2 up, 2 in
pgmap v729: 92 pgs, 4 pools, 136 MB data, 46 objects
23632 MB used, 31172 MB / 54805 MB avail
92 active+clean
But when i mount from client,the error is: mount error 5 = Input/output error.
I have tried lots of ways,for ex:disable selinux,update kernel...
Could anyone help me to resolve it? Thanks!
it's a bug in ceph mount helper. just ignore the error message, it's harmless.
Post by 于泓海
Jason
--
_______________________________________________
ceph-users mailing list
http://lists.ceph.com/listinfo.cgi/ceph-users-ceph.com
Yan, Zheng
2015-01-28 14:38:21 UTC
Permalink
Post by Yan, Zheng
Post by 于泓海
Hi:
I have completed the installation of ceph cluster,and the ceph health is
ok:
cluster 15ee68b9-eb3c-4a49-8a99-e5de64449910
health HEALTH_OK
monmap e1: 1 mons at {ceph01=10.194.203.251:6789/0}, election epoch 1,
quorum 0 ceph01
mdsmap e2: 0/0/1 up
osdmap e16: 2 osds: 2 up, 2 in
pgmap v729: 92 pgs, 4 pools, 136 MB data, 46 objects
23632 MB used, 31172 MB / 54805 MB avail
92 active+clean
But when i mount from client,the error is: mount error 5 = Input/output error.
I have tried lots of ways,for ex:disable selinux,update kernel...
Could anyone help me to resolve it? Thanks!
it's a bug in ceph mount helper. just ignore the error message, it's harmless.
sorry, I misread the error message. the ceph health message shows there is
no running MDS. you need to start MDS before mounting
Post by Yan, Zheng
Post by 于泓海
Jason
--
_______________________________________________
ceph-users mailing list
http://lists.ceph.com/listinfo.cgi/ceph-users-ceph.com
于泓海
2015-01-29 01:59:24 UTC
Permalink
Thanks ! I have resolved it with your suggestion.
Post by Yan, Zheng
Post by Yan, Zheng
Post by 于泓海
Hi£º
I have completed the installation of ceph cluster,and the ceph health is ok£º
cluster 15ee68b9-eb3c-4a49-8a99-e5de64449910
health HEALTH_OK
monmap e1: 1 mons at {ceph01=10.194.203.251:6789/0}, election epoch 1,
quorum 0 ceph01
mdsmap e2: 0/0/1 up
osdmap e16: 2 osds: 2 up, 2 in
pgmap v729: 92 pgs, 4 pools, 136 MB data, 46 objects
23632 MB used, 31172 MB / 54805 MB avail
92 active+clean
But when i mount from client,the error is: mount error 5 = Input/output error.
I have tried lots of ways,for ex:disable selinux,update kernel...
Could anyone help me to resolve it? Thanks!
it's a bug in ceph mount helper. just ignore the error message, it's harmless.
sorry, I misread the error message. the ceph health message shows there is
no running MDS. you need to start MDS before mounting
Post by Yan, Zheng
Post by 于泓海
Jason
--
_______________________________________________
ceph-users mailing list
http://lists.ceph.com/listinfo.cgi/ceph-users-ceph.com
于泓海
2015-01-28 03:24:35 UTC
Permalink
Hi£º


I have completed the installation of ceph cluster,and the ceph health is ok£º


cluster 15ee68b9-eb3c-4a49-8a99-e5de64449910
health HEALTH_OK
monmap e1: 1 mons at {ceph01=10.194.203.251:6789/0}, election epoch 1, quorum 0 ceph01
mdsmap e2: 0/0/1 up
osdmap e16: 2 osds: 2 up, 2 in
pgmap v729: 92 pgs, 4 pools, 136 MB data, 46 objects
23632 MB used, 31172 MB / 54805 MB avail
92 active+clean


But when i mount from client,the error is: mount error 5 = Input/output error.
I have tried lots of ways,for ex:disable selinux,update kernel...
Could anyone help me to resolve it? Thanks!




Jason



--

Loading...